Ubuntu 安装lua

1、下载lua的源码包
http://www.lua.org/ftp/lua-5.1.2.tar.gz

使用环境

ubuntu-16.04.4 64位

2、下载libreadline相关支持,这个东西在编译时需要用到
sudo apt-get install libreadline5
sudo apt-get install libreadline5-dev

安装步骤

  • 1>安装apache
  • 2>安装lua
  • 3>安装lua_filesystem

3、编译以及安装
tar xzvf lua-5.1.2.tar.gz
cd lua-5.1.2
make linux
sudo make install

安装apache

安装命令:

sudo apt-get install apache2

安装后的网站根目录是”/var/www/html”,如果需要修改可以配置conf文件

4、测试
$ lua
Lua 5.1.2 Copyright (C) 1994-2007 Lua.org, PUC-Rio
>

安装lua

可以下载安装包也可以使用apt-get下载

  • 使用apt-get

apt-get install lua5.3

可根据自己需要安装扩展:

apt-get install lua5.3-doc liblua5.3-dev

运行:lua5.3

  • 使用安装包
    cd到想要安装的目录

weget
http://www.lua.org/ftp/lua-5.3.4.tar.gz
tar -zxf lua-5.3.4.tar.gz
cd lua-5.3.4
make linux test

这时直接运行 #lua 是不成功的,需要cd到src文件夹中运行 #./lua
才可以,可以创建软连接:
ln -s **(存在位置)/lua-5.3.4/src/lua /usr/bin/lua

网站地图xml地图